読者です 読者をやめる 読者になる 読者になる

Oracle enhanced adapter 1.6.8 をリリースした

Rails 4.2.8 で Ruby 2.4 をサポートしたことに伴い、Unified Integer の警告ログが出るようになったというフィードバックの ISSUE をきっかけに、その ISSUE で yahonda さんに Rails 4.2 系に対応する oracle-enhanced 1.6 系のリリースの相談をしてみたのがきっかけ。

Rails 5.0 系に対応する oracle-enhanced 1.7 系からのバックポートを中心とした、だいたい1年ぶりの oracle-enhanced 1.6 系リリースで、Unified Integer の警告ログ以外にもいくつか修正点など入っている。

github.com

Google Groups にアナウンスした投稿が何故か反映されていない (Google Groups 弱者すぎる) ものの、Gem 自体のリリースはできているので Ruby 2.4.0 の Unified Integer まわりの警告が原因で Rails 4.2.8 にアップグレードできてない、Rails 4.2 系かつ Oracle ユーザーは特にアップグレードするのがおすすめ。