読者です 読者をやめる 読者になる 読者になる

backport_dig 1.0.0をリリースした

Ruby 2.1 公式サポート終了となり、Ruby 2.2 も来年3月に公式サポート終了の予定ということから backport_dig を 1.0.0 としてリリースしておいた。おそらく最後のリリース。

Ruby 2.3 で追加された dig 族のうち、Hash#dig / Array#dig / OpenStruct#dig の3つは Gem に切り出せたけれど、Struct#dig をネイティブ実装として切り出せていなかったのが 1.0.0 にしていない理由だったが、Ruby 2.2 の EOL が近くなったことからもう手を入れることもないだろうと餞別代わりに (何への?) 1.0.0 という数字を振っておいた。

github.com

gemspec の required_ruby_version で指定しているとおり、Ruby 2.0 / Ruby 2.1 / Ruby 2.2 以外はそもそもインストールできないようにしている。post_install_message にあるとおり Ruby 2.3 以降を使うのがベストです。