読者です 読者をやめる 読者になる 読者になる

activerecord-oracle_enhanced-adapter-monky_patch_755 (0.3.0) をリリースした

activerecord-oracle_enhanced-adapter-monky_patch_755 (0.3.0) をリリースした。

https://rubygems.org/gems/activerecord-oracle_enhanced-adapter-monky_patch_755/versions/0.3.0

実は、もともとの課題となっていた Issue へのワークアラウンドに加えて、Rails 4 から Rails 5 でのアップグレードで必要な OracleDATE 型から TIMESTAMP 型へのスキーママイグレーションをしていない場合の動きを維持するというものも入っている。

github.com

上記の移行ドキュメントにあるとおり、あくまでスキーママイグレーションを行なうのが正攻法のため、現在の Rails 5.1, Oracle enhanced adapter 1.8 が最後のサポートになる予定。